Get in touch
Back
Maintenance

Datacenter Maintenance

Completed 7 Dec at 06:00am GMT.

The Mason Foundation Website Propel People Website
Completed

Maintenance completed

Posted 7 Dec at 06:00am GMT.
Started

During the above window, the datacenter will be performing maintenance on core switches as part of their network upgrades.

Posted 7 Dec at 02:00am GMT.